From 3d2e2bf6b85b5d54e331b8572050a395be87d134 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Tue, 26 May 2020 09:49:11 +0300
Subject: [PATCH] gnu: go-github-com-prometheus-procfs: Update to 0.0.11.

* gnu/packages/syncthing.scm (go-github-com-prometheus-procfs): Update
to 0.0.11.
[propagated-inputs]: Add go-golang-org-x-sys.
---
 gnu/packages/syncthing.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 6ae7b7b024b..be7496e7ca8 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -878,7 +878,7 @@ (define-public go-github-com-prometheus-common
 (define-public go-github-com-prometheus-procfs
     (package
       (name "go-github-com-prometheus-procfs")
-      (version "0.0.4")
+      (version "0.0.11")
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
@@ -887,13 +887,15 @@ (define-public go-github-com-prometheus-procfs
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "1z5jq5rjala0a0di4nwk1rai0z9f73qwqj6mgcbpjbg2qknlb544"))))
+                  "1msc8bfywsmrgr2ryqjdqwkxiz1ll08r3qgvaka2507z1wpcpj2c"))))
       (build-system go-build-system)
       (arguments
        '(#:import-path "github.com/prometheus/procfs"
          ;; The tests require Go modules, which are not yet supported in Guix's
          ;; Go build system.
          #:tests? #f))
+      (propagated-inputs
+       `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
       (synopsis "Go library for reading @file{/proc}")
       (description "The @code{procfs} Go package provides functions to retrieve
 system, kernel, and process metrics from the @file{/proc} pseudo file system.")
-- 
GitLab