diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ee2fc11eb10ddbdb81a0516ae045584a99d3ad1d..6bb2a5a5be4b1fb8960e4d92f89a0c23b625ef07 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5008,6 +5008,7 @@ (define-public python-importlib-metadata
 @code{pkg_resources} entry point API and metadata API.  Along with
 @code{importlib.resources} in Python 3.7 and newer, this can eliminate the
 need to use the older and less efficient @code{pkg_resources} package.")
+    (properties `((python2-variant . ,(delay python2-importlib-metadata))))
     (license license:asl2.0)))
 
 (define-public python2-importlib-metadata