From 3fb8041c0dbd26c18a611951af48ba34c951b59f Mon Sep 17 00:00:00 2001
From: ng0 <ng0@n0.is>
Date: Mon, 4 Dec 2017 22:08:53 +0000
Subject: [PATCH] gnu: guile-wm and guile-xcb: Build with guile-2.2.

* gnu/packages/guile-wm.scm (guile-wm): Build with guile-2.2.
(arguments)[configure-flags]: Replace references of "2.0" with "2.2".
(inputs): Use guile-2.2.
* (guile-xcb): Build with guile-2.2.
(arguments)[configure-flags] Use Guile 2.2.

Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
---
 gnu/packages/guile-wm.scm | 18 +++++++++---------
 1 file changed, 9 insertions(+), 9 deletions(-)

diff --git a/gnu/packages/guile-wm.scm b/gnu/packages/guile-wm.scm
index 7f302668ab5..918761259fe 100644
--- a/gnu/packages/guile-wm.scm
+++ b/gnu/packages/guile-wm.scm
@@ -53,14 +53,14 @@ (define-public guile-xcb
                  #:configure-flags (list (string-append
                                           "--with-guile-site-dir="
                                           (assoc-ref %outputs "out")
-                                          "/share/guile/site/2.0")
+                                          "/share/guile/site/2.2")
                                          (string-append
                                           "--with-guile-site-ccache-dir="
                                           (assoc-ref %outputs "out")
-                                          "/share/guile/site/2.0"))))
+                                          "/share/guile/site/2.2"))))
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("texinfo" ,texinfo)))
-    (inputs `(("guile" ,guile-2.0)
+    (inputs `(("guile" ,guile-2.2)
               ("xcb" ,xcb-proto)))
     (home-page "https://github.com/mwitmer/guile-xcb")
     (synopsis "XCB bindings for Guile")
@@ -92,17 +92,17 @@ (define-public guile-wm
        ;; standard value.
        #:configure-flags (list (string-append "--datadir="
                                               (assoc-ref %outputs "out")
-                                              "/share/guile/site/2.0"))
+                                              "/share/guile/site/2.2"))
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'set-go-directory
           (lambda* (#:key outputs #:allow-other-keys)
-            ;; Install .go files to $out/share/guile/site/2.0.
+            ;; Install .go files to $out/share/guile/site/2.2.
             (let ((out (assoc-ref outputs "out")))
               (substitute* "module/Makefile.in"
                 (("^wmdir = .*$")
                  (string-append "wmdir = " out
-                                "/share/guile/site/2.0\n"))))
+                                "/share/guile/site/2.2\n"))))
             #t))
          (add-after 'install 'set-load-path
            (lambda* (#:key inputs outputs #:allow-other-keys)
@@ -111,10 +111,10 @@ (define-public guile-wm
              (let* ((out  (assoc-ref outputs "out"))
                     (prog (string-append out "/bin/guile-wm"))
                     (mods (string-append
-                           out "/share/guile/site/2.0"))
+                           out "/share/guile/site/2.2"))
                     (xcb  (string-append
                            (assoc-ref inputs "guile-xcb")
-                           "/share/guile/site/2.0")))
+                           "/share/guile/site/2.2")))
                (wrap-program
                    prog
                  `("GUILE_LOAD_PATH" ":" prefix (,mods ,xcb))
@@ -140,7 +140,7 @@ (define-public guile-wm
              #t)))))
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("texinfo" ,texinfo)))
-    (inputs `(("guile" ,guile-2.0)
+    (inputs `(("guile" ,guile-2.2)
               ("guile-xcb" ,guile-xcb)))
     (home-page "https://github.com/mwitmer/guile-wm/releases")
     (description
-- 
GitLab