From 402d03751c03e509b9aee1f26eed40cae81eebba Mon Sep 17 00:00:00 2001
From: Marius Bakke <marius@gnu.org>
Date: Mon, 22 Jun 2020 16:57:13 +0200
Subject: [PATCH] gnu: ffmpeg: Enable rav1e on x86_64 only.

Fixes <https://bugs.gnu.org/41993>.
Reported by Kurt I <gitlabcanada@runbox.com>.

* gnu/packages/video.scm (ffmpeg)[inputs]: Conditionally add RAV1E.
[arguments]: Adjust #:configure-flags accordingly.
---
 gnu/packages/video.scm | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 4e521473fed..eabd6577987 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -971,7 +971,12 @@ (define-public ffmpeg
        ("mesa" ,mesa)
        ("openal" ,openal)
        ("pulseaudio" ,pulseaudio)
-       ("rav1e" ,rav1e)
+       ;; XXX: rav1e depends on rust, which currently only works on x86_64.
+       ;; See also the related configure flag when changing this.
+       ,@(if (string-prefix? "x86_64" (or (%current-target-system)
+                                          (%current-system)))
+             `(("rav1e" ,rav1e))
+             '())
        ("sdl" ,sdl2)
        ("soxr" ,soxr)
        ("speex" ,speex)
@@ -1053,7 +1058,10 @@ (define-public ffmpeg
          "--enable-libmp3lame"
          "--enable-libopus"
          "--enable-libpulse"
-         "--enable-librav1e"
+         ,@(if (string-prefix? "x86_64" (or (%current-target-system)
+                                            (%current-system)))
+               '("--enable-librav1e")
+               '())
          "--enable-libsoxr"
          "--enable-libspeex"
          "--enable-libtheora"
-- 
GitLab