diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 234ea338a1460d1c9297b999fa8a5c83ed672add..4684fce1303f3bed5ebdc4a3de3dd54cb6702c71 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -385,7 +385,7 @@ (define-public perl-compress-raw-zlib
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-before
-                   configure configure-zlib
+                   'configure 'configure-zlib
                    (lambda* (#:key inputs #:allow-other-keys)
                      (call-with-output-file "config.in"
                        (lambda (port)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 723b6d2d72c6d746b2d4af419496e2285bbcc8d0..e55eb8791dc81c54ba21e54181df1dcfc50c10ee 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2486,7 +2486,7 @@ (define-public perl-ipc-run
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-before
-                   check disable-w32-test
+                   'check 'disable-w32-test
                    (lambda _
                      ;; This test fails, and we're not really interested in
                      ;; it, so disable it.
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 739f3fc3849ccd24ca537f929638264f0930e803..d30c40ce1a4fbadcd27f205b824efd48f1bd0863 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -245,7 +245,7 @@ (define-public perl-xml-sax
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (add-before
-                   install augment-path
+                   'install 'augment-path
                    ;; The install target tries to load the newly-installed
                    ;; XML::SAX module, but can't find it, so we need to tell
                    ;; perl where to look.