From 429fdea1abbdf4884acb4441da458f65fc08e9df Mon Sep 17 00:00:00 2001
From: Eric Dvorsak <eric@dvorsak.fr>
Date: Sat, 25 Jul 2015 21:38:04 +0200
Subject: [PATCH] gnu: Add python-paramiko.

* gnu/packages/python.scm (python-paramiko, python2-paramiko): New variables.

Signed-off-by: Alex Kost <alezost@gmail.com>
---
 gnu/packages/python.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ab89fd0d60f..3ee46f37595 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -298,6 +298,38 @@ (define-public python-psutil
 (define-public python2-psutil
   (package-with-python2 python-psutil))
 
+(define-public python-paramiko
+  (package
+    (name "python-paramiko")
+    (version "1.15.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/p/paramiko/paramiko-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0mbfzm9zlrz6mla9xakrm8wkll3x035f9rj3c5pbgjzfldqscmjg"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (inputs
+     `(("python-ecdsa" ,python-ecdsa)
+       ("python-pycrypto" ,python-pycrypto)))
+    (home-page "http://www.paramiko.org/")
+    (synopsis "SSHv2 protocol library")
+    (description "Paramiko is a python implementation of the SSHv2 protocol,
+providing both client and server functionality.  While it leverages a Python C
+extension for low level cryptography (PyCrypto), Paramiko itself is a pure
+Python interface around SSH networking concepts.")
+    (license lgpl2.1+)))
+
+(define-public python2-paramiko
+  (package-with-python2 python-paramiko))
+
+
 (define-public python-httplib2
   (package
     (name "python-httplib2")
-- 
GitLab