From 450226ebc1b2611ff62469d314e7ca2973bbf131 Mon Sep 17 00:00:00 2001
From: Hartmut Goebel <h.goebel@crazy-compilers.com>
Date: Sun, 23 Dec 2018 23:01:55 +0100
Subject: [PATCH] gnu: baloo: Fix build.

The substitute for removing a failing test did no longer work since
the way the test is included changed in v5.45.0: Formerly the test
has listed, now there is a separate statement for this test.

* gnu/package/kde-frameworks.scm((baloo)[arguments]<#phases>: Change
  substitute in phase 'remove-failing-test'.
---
 gnu/packages/kde-frameworks.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index f5a084a7e85..bc28511d3fc 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2003,7 +2003,8 @@ (define-public baloo
            ;; This test fails on i686 and aarch64
            (lambda _
              (substitute* "autotests/unit/file/CMakeLists.txt"
-               (("metadatamovertest") ""))
+               (("^\\s*ecm_add_test\\(.* TEST_NAME metadatamovertest .*" line)
+                (string-append "# " line)))
              #t))
          (replace 'check
            (lambda _
-- 
GitLab