From 455d29dda6e1798e8f004296024db6658645a3e6 Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Sun, 23 Jun 2019 20:07:34 +0200
Subject: [PATCH] gnu: python-parted: Don't use unstable tarball.

* gnu/packages/disk.scm (python-parted)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
---
 gnu/packages/disk.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 50b28e9d026..06f4430b2de 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -442,11 +442,13 @@ (define-public python-parted
     (version "3.11.2")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/dcantrell/pyparted/archive/v"
-                           version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dcantrell/pyparted.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "18727vdscrdi2sza9la0y2xxfc4cqfl0ivjigx6m1q16jnaz84ml"))))
+        (base32 "0r6916n3w4vldxrq30a3z2iagvxgly4vfmlidjm65vwqnyv17bvn"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
-- 
GitLab