diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 549bd347c122caa99f075ef1cf79f0a41a6dbe46..888e1c30ed70e53d8387c00fcbfc723f1ac7faa7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9104,8 +9104,9 @@ (define-public python-twisted
                 "0ydxrp9myw1mvsz3qfzx5579y5llmqa82pxvqchgp5syczffi450"))))
     (build-system python-build-system)
     (native-inputs
-     `(("python-setuptools" ,python-setuptools)
-       ("python-zope-interface" ,python-zope-interface)))
+     `(("python-setuptools" ,python-setuptools)))
+    (propagated-inputs
+     `(("python-zope-interface" ,python-zope-interface)))
     (home-page "https://twistedmatrix.com/")
     (synopsis "Asynchronous networking framework written in Python")
     (description