From 45aba232abe50b6642abfaa06030985c7febbe07 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Fri, 29 Mar 2019 07:14:17 +0100
Subject: [PATCH] gnu: stepmania: Fix loading of gtk module.

Fixes <https://bugs.gnu.org/34854>.

Suggested by Nicolas Goaziou.

* gnu/packages/games.scm (stepmania)[arguments]: Add phase
"ensure-gtk-module-can-be-found".
---
 gnu/packages/games.scm | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a5ea5cd39ac..c7e08f8d981 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6182,6 +6182,13 @@ (define-public stepmania
                             "/lib/glib-2.0/include"))
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'ensure-gtk-module-can-be-found
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "src/arch/LoadingWindow/LoadingWindow_Gtk.cpp"
+               (("RageFileManagerUtil::sDirOfExecutable \\+ \"/\" \\+ \"GtkModule.so\"")
+                (string-append "\"" (assoc-ref outputs "out")
+                               "/share/stepmania/GtkModule.so\"")))
+             #t))
          (add-after 'unpack 'fix-install-subdir
            ;; Installation would be done in "%out/stepmania-X.Y", but we
            ;; prefer the more common layout "%out/share/stepmania".
-- 
GitLab