diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4e0a67a1e8df223a0d8765fddad6f369d49d8b15..51382184d21a827f8b794cb19a9fb4059005cd23 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13581,6 +13581,7 @@ (define-public python-send2trash
     (synopsis "Send files to the user's @file{~/Trash} directory")
     (description "This package provides a Python library to send files to the
 user's @file{~/Trash} directory.")
+    (properties `((python2-variant . ,(delay python-send2trash))))
     (license license:bsd-3)))
 
 (define-public python2-send2trash
@@ -13594,8 +13595,7 @@ (define-public python2-send2trash
              (lambda _
                (setenv "PYTHONPATH"
                        (string-append (getcwd) ":" (getenv "PYTHONPATH")))
-               #t))))))
-    (properties `((python2-variant . ,(delay python-send2trash))))))
+               #t))))))))
 
 (define-public python-yapf
   (package