diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 18319b5d07960d7e8176747940f388a31d04bb02..46e9b0237a8b947fd060ca3f820e4cde218d0db7 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -329,10 +329,11 @@ (define-public libetonyek
        ("doxygen" ,doxygen)
        ("gperf" ,gperf)
        ("pkg-config" ,pkg-config)))
-    (inputs
-     `(("boost" ,boost)
-       ("librevenge" ,librevenge)
+    (propagated-inputs ; in Requires or Requires.private field of .pkg
+     `(("librevenge" ,librevenge)
        ("libxml2" ,libxml2)))
+    (inputs
+     `(("boost" ,boost)))
     (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libetonyek")
     (synopsis "Library for parsing the Apple Keynote format")
     (description "Libetonyek is a library that parses the file format of