From 48dbeef733b60299b8b54f64a4b1c6676b86d8fc Mon Sep 17 00:00:00 2001
From: Federico Beffa <beffa@fbengineering.ch>
Date: Thu, 23 Jul 2015 18:58:26 +0200
Subject: [PATCH] gnu: Add emacs-ob-ipython.

* gnu/packages/emacs.scm (emacs-ob-ipython): New variable.
---
 gnu/packages/emacs.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c2a9bb6c5c8..b73d80c8635 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -983,3 +983,24 @@ (define-public emacs-f
     (description "This package provides an Emacs library for working with
 files and directories.")
     (license license:gpl3+)))
+
+(define-public emacs-ob-ipython
+  (package
+    (name "emacs-ob-ipython")
+    (version "20150704.8807064693")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (commit "8807064693")
+                    (url "https://github.com/gregsexton/ob-ipython.git")))
+              (sha256
+               (base32
+                "1scf25snbds9ymagpny30ijbsg479r3nm0ih01dy4m9d0g7qryb7"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-f" ,emacs-f)))
+    (home-page "http://www.gregsexton.org")
+    (synopsis "Org-Babel functions for IPython evaluation")
+    (description "This package adds support to Org-Babel for evaluating Python
+source code using IPython.")
+    (license license:gpl3+)))
-- 
GitLab