diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 40ab048316e92adf8052211f2a8d14cdda930b00..a877fe5ca26df0744be4149f22575922974898e6 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2185,17 +2185,6 @@ (define-public armadillo
 associated functions (eg. contiguous and non-contiguous submatrix views).")
     (license license:mpl2.0)))
 
-(define-public armadillo-for-rcpparmadillo
-  (package (inherit armadillo)
-    (version "7.600.1")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://sourceforge/arma/armadillo-"
-                                  version ".tar.xz"))
-              (sha256
-               (base32
-                "1dxgfd2r9lbh24nszvqm2lag439s0srxaf1l86f6ww6waqm5r8zk"))))))
-
 (define-public muparser
   ;; When switching download sites, muparser re-issued a 2.2.5 release with a
   ;; different hash. In order to make `guix package --upgrade` work correctly,