diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 09d123a08d8b3f290954697f1eb624c467caba2b..3ffe2a4cddfd6d3f14f6ac1e62beb7ab39bf92c1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1273,7 +1273,18 @@ (define-public kmod
        ("zlib" ,guix:zlib)))
     (arguments
      `(#:tests? #f ; FIXME: Investigate test failures
-       #:configure-flags '("--with-xz" "--with-zlib")))
+       #:configure-flags '("--with-xz" "--with-zlib")
+       #:phases (alist-cons-after
+                 'install 'install-modprobe&co
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let* ((out (assoc-ref outputs "out"))
+                          (bin (string-append out "/bin")))
+                     (for-each (lambda (tool)
+                                 (symlink "kmod"
+                                          (string-append bin "/" tool)))
+                               '("insmod" "rmmod" "lsmod" "modprobe"
+                                 "modinfo" "depmod"))))
+                 %standard-phases)))
     (home-page "https://www.kernel.org/")
     (synopsis "Kernel module tools")
     (description "kmod is a set of tools to handle common tasks with Linux