From 4a8b4c25b07eedd1427d8c33c01d0c7d6a0f17b5 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Wed, 23 Jul 2014 19:09:27 +0200
Subject: [PATCH] gnu: kmod: Install symlinks for 'insmod', 'modprobe', etc.

* gnu/packages/linux.scm (kmod)[arguments]: Add 'install-modprobe&co'
  phase.
---
 gnu/packages/linux.scm | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 09d123a08d8..3ffe2a4cddf 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1273,7 +1273,18 @@ (define-public kmod
        ("zlib" ,guix:zlib)))
     (arguments
      `(#:tests? #f ; FIXME: Investigate test failures
-       #:configure-flags '("--with-xz" "--with-zlib")))
+       #:configure-flags '("--with-xz" "--with-zlib")
+       #:phases (alist-cons-after
+                 'install 'install-modprobe&co
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let* ((out (assoc-ref outputs "out"))
+                          (bin (string-append out "/bin")))
+                     (for-each (lambda (tool)
+                                 (symlink "kmod"
+                                          (string-append bin "/" tool)))
+                               '("insmod" "rmmod" "lsmod" "modprobe"
+                                 "modinfo" "depmod"))))
+                 %standard-phases)))
     (home-page "https://www.kernel.org/")
     (synopsis "Kernel module tools")
     (description "kmod is a set of tools to handle common tasks with Linux
-- 
GitLab