diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 522404f28030547e2778ee29d14e21ebf6925d87..8031a6c4cee07423cbf3b7020f5bc6183e48aeda 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -85,7 +85,12 @@ (define-public mozjs
     (synopsis "Mozilla javascript engine")
     (description "SpiderMonkey is Mozilla's JavaScript engine written
 in C/C++.")
-    (license license:mpl2.0))) ; and others for some files
+    (license license:mpl2.0)                      ;and others for some files
+
+    ;; On mips64el, this fails to build with several "control reaches end of
+    ;; non-void function" errors (see
+    ;; <http://hydra.gnu.org/build/407741/nixlog/3/raw>.)
+    (supported-systems (delete "mips64el-linux" %supported-systems))))
 
 (define-public nspr
   (package