diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 575569d3aa59ed15eed06d34dd8ff61cd0f3f6e7..4d2d343ade41c105e22fcac09f12e1f41674b6da 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -733,14 +733,14 @@ (define-public python2-ledgerblue
 (define-public python-trezor
   (package
     (name "python-trezor")
-    (version "0.11.1")
+    (version "0.11.2")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "trezor" version))
         (sha256
           (base32
-            "064yds8f4px0c6grkkanpdjx022g4q87ihzhkmdv9qanv0hz6hv0"))))
+            "1f0zfki12mnhidkfxpx2lpq1xim8f35i2d64bx9lf4m26xxv9x56"))))
     (build-system python-build-system)
     (arguments
      `(#:phases