diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ea183c030175c6404466aa5397cb36699ef242b2..991082eed0f07cfa9fc5fb962dcd613016e928ad 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14755,6 +14755,10 @@ (define-public python-parso
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _ (invoke "pytest" "-vv"))))))
     (home-page "https://github.com/davidhalter/parso")
     (synopsis "Python Parser")
     (description "Parso is a Python parser that supports error recovery and