From 4eb97c254effc95115d5e9da1b7083ecbc427a2f Mon Sep 17 00:00:00 2001
From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Date: Tue, 10 Sep 2019 22:34:22 +0900
Subject: [PATCH] gnu: python-parso: Run the test suite.

* gnu/packages/python-xyz.scm (python-parso)[phases]: Replace the check phase.
---
 gnu/packages/python-xyz.scm | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ea183c03017..991082eed0f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14755,6 +14755,10 @@ (define-public python-parso
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _ (invoke "pytest" "-vv"))))))
     (home-page "https://github.com/davidhalter/parso")
     (synopsis "Python Parser")
     (description "Parso is a Python parser that supports error recovery and
-- 
GitLab