From 4ec48644c3b3760bcc8a72eb6956c678b57182a1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@gmail.com>
Date: Sat, 4 Apr 2015 12:39:31 +0800
Subject: [PATCH] gnu: gst-plugins-base: Enable GObjection introspection.

* gnu/packages/gstreamer.scm (gst-plugins-base): Add gobject-introspection
  to 'native-inputs'.
  [arguments]<#:phases>: Rename patch-test-pb-utils to patch.  Add
  (setenv "CC" "gcc") to patch phase.
---
 gnu/packages/gstreamer.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index e941f8b2a09..ad0cfccca9b 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -176,6 +176,7 @@ (define-public gst-plugins-base
     (native-inputs
       `(("pkg-config" ,pkg-config)
         ("glib" ,glib "bin")
+        ("gobject-introspection" ,gobject-introspection)
         ("python-wrapper" ,python-wrapper)))
     (arguments
      `(#:configure-flags
@@ -184,10 +185,12 @@ (define-public gst-plugins-base
                             "/share/gtk-doc/html"))
        #:phases
        (alist-cons-before
-        'configure 'patch-test-pb-utils
+        'configure 'patch
         (lambda _
           (substitute* "tests/check/libs/pbutils.c"
-            (("/bin/sh") (which "sh"))))
+            (("/bin/sh") (which "sh")))
+          ;; for g-ir-scanner.
+          (setenv "CC" "gcc"))
         %standard-phases)))
     (home-page "http://gstreamer.freedesktop.org/")
     (synopsis
-- 
GitLab