diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 4d2d343ade41c105e22fcac09f12e1f41674b6da..4d35872fe4b655671da60c9fd2830aab2b95216e 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -779,14 +779,14 @@ (define-public python2-trezor
 (define-public python-keepkey
   (package
     (name "python-keepkey")
-    (version "6.0.2")
+    (version "6.0.3")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "keepkey" version))
         (sha256
           (base32
-            "16j8hnxj9r4b2w6kfncmny09pb1al8ppmn59qxzl3qmh1xhpy45g"))))
+            "0z3d0m6364v9dv0njs4cd5m5ai6j6v35xaaxfxl90m9vmyxy81vd"))))
     (build-system python-build-system)
     (arguments
      `(#:phases