From 52323f32fa3d5c93249b7d76f9c7a1f1e906c86b Mon Sep 17 00:00:00 2001
From: Eric Dvorsak <eric@dvorsak.fr>
Date: Sat, 25 Jul 2015 21:34:19 +0200
Subject: [PATCH] gnu: Add python-ccm.

* gnu/packages/python.scm (python-ccm, python2-ccm): New variables.

Signed-off-by: Alex Kost <alezost@gmail.com>
---
 gnu/packages/python.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 88ab4427e17..a3802a42e01 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -298,6 +298,35 @@ (define-public python-psutil
 (define-public python2-psutil
   (package-with-python2 python-psutil))
 
+(define-public python-ccm
+  (package
+    (name "python-ccm")
+    (version "2.0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/c/ccm/ccm-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "199jw221albs2iv6xczczq88fxnh0aw8hzmys8qkbzkd99dssng9"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (inputs
+     `(("python-pyyaml" ,python-pyyaml)
+       ("python-six" ,python-six)))
+    (home-page "https://github.com/pcmanus/ccm")
+    (synopsis "Cassandra Cluster Manager")
+    (description "A script/library to create, launch and remove an Apache
+Cassandra cluster on localhost.")
+    (license asl2.0)))
+
+(define-public python2-ccm
+  (package-with-python2 python-ccm))
+
 (define-public python-pytz
   (package
     (name "python-pytz")
-- 
GitLab