From 53ac6977ac0bbd766d014d3b0aefea3958bbf54f Mon Sep 17 00:00:00 2001
From: Oleg Pykhalov <go.wigust@gmail.com>
Date: Wed, 26 Jul 2017 15:48:12 +0300
Subject: [PATCH] gnu: tome4: Clean up snippet.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/games.scm (tome4)[source](snippet): Use a single
'substitute*' call instead of 'for-each'.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/games.scm | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 071311a7511..d859a6398c7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4633,12 +4633,10 @@ (define-public tome4
          "0v2qgdfpvdzd1bcbp9v8pfahj1bgczsq2d4xfhh5wg11jgjcwz03"))
        (modules '((guix build utils)))
        (snippet
-        '(for-each (lambda (file)
-                     (substitute* file
-                       (("#elif defined(__FreeBSD__)" line)
-                        (string-append
-                         line " || defined(__GNUC__)"))))
-                   '("src/music.h" "src/tSDL.h")))))
+        '(substitute* '("src/music.h" "src/tSDL.h")
+           (("#elif defined(__FreeBSD__)" line)
+            (string-append
+             line " || defined(__GNUC__)"))))))
     (build-system gnu-build-system)
     (native-inputs
      `(("unzip" ,unzip)))
-- 
GitLab