diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 369110a044092353cdbf37271d1de6e7bdab81a9..96526cbbf6f2a4dbb40bf8a58adbadc99b158340 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1358,11 +1358,11 @@ (define-public radare2
              "--with-openssl" "--with-rpath")
        #:make-flags
        (list "CC=gcc")))
+    ;; TODO: Add gmp and libzip and make the build system actually find them.
     (inputs
-     `(("openssl" ,openssl)
-       ("zip" ,zip)
-       ("gmp" ,gmp)
-       ("capstone" ,capstone)))
+     `(("capstone" ,capstone)
+       ("openssl" ,openssl)
+       ("zip" ,zip)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (home-page "https://radare.org/")