diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index ea4d2de725e0e28791e23e00b305b92c7db6f7cc..f107beff6ffb9e5f326fc2ebb603c4ce923fd8cf 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1862,13 +1862,16 @@ (define bison-boot0
                   (propagated-inputs `(("m4" ,m4)))
                   (inputs '())                    ;remove Flex...
                   (arguments
-                   '(#:tests? #f                  ;... and thus disable tests
+                   `(#:tests? #f                  ;... and thus disable tests
 
                      ;; Zero timestamps in liby.a; this must be done
                      ;; explicitly here because the bootstrap Binutils don't
                      ;; do that (default is "cru".)
-                     #:make-flags '("ARFLAGS=crD"
-                                    "RANLIB=ranlib -D"
+                     #:make-flags `("ARFLAGS=crD"
+                                    ,,(match (%current-system)
+                                      ;; ranlib: '-D': No such file
+                                      ("i686-linux" "RANLIB=ranlib")
+                                      (_ "RANLIB=ranlib -D"))
                                     "V=1"))))))
     (package
       (inherit (package-with-bootstrap-guile