From 56f45b7c785dd576d023c45c5603ab907da912fe Mon Sep 17 00:00:00 2001
From: Jan Nieuwenhuizen <janneke@gnu.org>
Date: Tue, 18 Sep 2018 23:18:40 +0200
Subject: [PATCH] bootstrap: bison-boot0: Do not use `ranlib -D'.

* gnu/packages/commencement.scm (bison-boot0): Do not use `ranlib -D' for
i686-linux bootstrap.
---
 gnu/packages/commencement.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index ea4d2de725e..f107beff6ff 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1862,13 +1862,16 @@ (define bison-boot0
                   (propagated-inputs `(("m4" ,m4)))
                   (inputs '())                    ;remove Flex...
                   (arguments
-                   '(#:tests? #f                  ;... and thus disable tests
+                   `(#:tests? #f                  ;... and thus disable tests
 
                      ;; Zero timestamps in liby.a; this must be done
                      ;; explicitly here because the bootstrap Binutils don't
                      ;; do that (default is "cru".)
-                     #:make-flags '("ARFLAGS=crD"
-                                    "RANLIB=ranlib -D"
+                     #:make-flags `("ARFLAGS=crD"
+                                    ,,(match (%current-system)
+                                      ;; ranlib: '-D': No such file
+                                      ("i686-linux" "RANLIB=ranlib")
+                                      (_ "RANLIB=ranlib -D"))
                                     "V=1"))))))
     (package
       (inherit (package-with-bootstrap-guile
-- 
GitLab