diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index e509647eae08a6131fc2beca76e12897be7ccbf1..cf4ac5351a443d8fd90e050a78f431014be4436e 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -509,7 +509,8 @@ (define-public propeller-gcc-4
                   (origin-patches (package-source gcc-4.7))
                   (search-patches "gcc-4.6-gnu-inline.patch"
                                   "gcc-cross-environment-variables.patch")))))
-      (home-page "https://github.com/dbetz/propgcc-gcc"))))
+      (home-page "https://github.com/dbetz/propgcc-gcc")
+      (supported-systems (delete "aarch64-linux" %supported-systems)))))
 
 ;; Version 6 is experimental and may not work correctly.  This is why we
 ;; default to version 4, which is also used in the binary toolchain bundle