From 596fcbf768828bb88c28107c6312e63f8329f430 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Sat, 27 Sep 2014 17:26:22 +0200
Subject: [PATCH] build: Don't generate Emacs autoloads when Emacs is
 unavailable.

Reported by Andreas Enge.

* configure.ac: Define 'HAVE_EMACS' Automake conditional.
* emacs.am ($(AUTOLOADS)): Wrap in 'if HAVE_EMACS'.
---
 configure.ac | 2 ++
 emacs.am     | 4 ++++
 2 files changed, 6 insertions(+)

diff --git a/configure.ac b/configure.ac
index 698dd857847..e516fa57b7a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,6 +176,8 @@ AC_CONFIG_FILES([test-env],     [chmod +x test-env])
 
 dnl Emacs interface.
 AM_PATH_LISPDIR
+AM_CONDITIONAL([HAVE_EMACS], [test "x$EMACS" != "xno"])
+
 emacsuidir="${guilemoduledir}/guix/emacs"
 AC_SUBST([emacsuidir])
 AC_CONFIG_FILES([emacs/guix-init.el
diff --git a/emacs.am b/emacs.am
index 86ae3a2c9f2..6ef9d1c326d 100644
--- a/emacs.am
+++ b/emacs.am
@@ -34,6 +34,8 @@ dist_lisp_DATA =				\
 nodist_lisp_DATA =				\
   emacs/guix-init.el
 
+if HAVE_EMACS
+
 $(AUTOLOADS): $(ELFILES)
 	$(EMACS) --batch --eval						\
 	  "(let ((backup-inhibited t)					\
@@ -41,3 +43,5 @@ $(AUTOLOADS): $(ELFILES)
 	          (expand-file-name \"$(AUTOLOADS)\" \"$(srcdir)\")))	\
 	     (update-directory-autoloads				\
 	      (expand-file-name \"emacs\" \"$(srcdir)\")))"
+
+endif HAVE_EMACS
-- 
GitLab