From 59f129855888b18bd0ff39d2427841d9c6714b57 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Sat, 29 Oct 2016 22:09:39 -0400
Subject: [PATCH] gnu: python-nltk: Disable the test suite.

The tests were silently skipped with Python 3.4. With Python 3.5, this caused
the build of python-nltk to fail.

* gnu/packages/python.scm (python-nltk, python2-nltk)[arguments]:
Disable the tests.
---
 gnu/packages/python.scm | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1247e5ef701..4e0292e1a70 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10456,6 +10456,10 @@ (define-public python-nltk
                (base32
                 "0skxbhnymwlspjkzga0f7x1hg3y50fwpfghs8g8k7fh6f4nknlym"))))
     (build-system python-build-system)
+    (arguments
+     '(;; The tests require some extra resources to be downloaded.
+       ;; TODO Try packaging these resources.
+       #:tests? #f))
     (home-page "http://nltk.org/")
     (synopsis "Natural Language Toolkit")
     (description "It provides interfaces to over 50 corpora and lexical
-- 
GitLab