From 5a4990b98260ba85b8b93d6ac43d871e370d6983 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sat, 22 Aug 2020 18:40:12 +0200
Subject: [PATCH] gnu: lesspipe: Patch paths to inputs.

* gnu/packages/less.scm (lesspipe)[arguments]: Add phase to patch
paths to tput and file.

Signed-off-by: Leo Famulari <leo@famulari.name>
---
 gnu/packages/less.scm | 12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/less.scm b/gnu/packages/less.scm
index f6ee355b68f..7c5107de092 100644
--- a/gnu/packages/less.scm
+++ b/gnu/packages/less.scm
@@ -80,7 +80,17 @@ (define-public lesspipe
                         (invoke "./configure"
                                 (string-append "--prefix=" out)
                                 "--yes")
-                        #t))))))
+                        #t)))
+                  (add-before 'install 'patch-tput-and-file
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (substitute* "lesspipe.sh"
+                        (("tput colors")
+                         (string-append (assoc-ref inputs "ncurses")
+                                        "/bin/tput colors"))
+                        (("file -")
+                         (string-append (assoc-ref inputs "file")
+                                        "/bin/file -")))
+                      #t)))))
     (inputs
      `(("file" ,file)
        ("ncurses" ,ncurses)))  ; for tput
-- 
GitLab