From 5b720c15d1842b203d133ba46d91749f66ba07cc Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Sun, 24 Nov 2019 14:06:16 +0100
Subject: [PATCH] gnu: r-pheatmap: Move to (gnu packages cran).

* gnu/packages/statistics.scm (r-pheatmap): Move from here...
* gnu/packages/cran.scm (r-pheatmap): ...to here.
---
 gnu/packages/cran.scm       | 23 +++++++++++++++++++++++
 gnu/packages/statistics.scm | 24 ------------------------
 2 files changed, 23 insertions(+), 24 deletions(-)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 82ff17db071..d6127196a03 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -123,6 +123,29 @@ (define-public r-scales
 legends.")
     (license license:expat)))
 
+(define-public r-pheatmap
+  (package
+    (name "r-pheatmap")
+    (version "1.0.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "pheatmap" version))
+       (sha256
+        (base32
+         "1hdh74az3vyzz6dqa311rhxdm74n46lyr03p862kn80p0kp9d7ap"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-gtable" ,r-gtable)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)
+       ("r-scales" ,r-scales)))
+    (home-page "https://cran.r-project.org/web/packages/pheatmap")
+    (synopsis "Pretty heatmaps")
+    (description
+     "This package provides an implementation of heatmaps that offers more
+control over dimensions and appearance.")
+    (license license:gpl2+)))
+
 (define-public r-ellipsis
   (package
     (name "r-ellipsis")
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index ea91126c74a..a83e792ef06 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -848,30 +848,6 @@ (define-public r-estimability
 non-estimable cases correctly.")
     (license license:gpl2+)))
 
-(define-public r-pheatmap
-  (package
-    (name "r-pheatmap")
-    (version "1.0.12")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (cran-uri "pheatmap" version))
-       (sha256
-        (base32
-         "1hdh74az3vyzz6dqa311rhxdm74n46lyr03p862kn80p0kp9d7ap"))))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-gtable" ,r-gtable)
-       ("r-rcolorbrewer" ,r-rcolorbrewer)
-       ("r-scales" ,r-scales)))
-    (home-page
-     "https://cran.r-project.org/web/packages/pheatmap")
-    (synopsis "Pretty heatmaps")
-    (description
-     "This package provides an implementation of heatmaps that offers more
-control over dimensions and appearance.")
-    (license license:gpl2+)))
-
 (define-public r-labeling
   (package
     (name "r-labeling")
-- 
GitLab