From 5fe12be0dd03d1a316343549f8c131d931f21a9a Mon Sep 17 00:00:00 2001
From: Mathieu Othacehe <othacehe@gnu.org>
Date: Mon, 24 Aug 2020 13:55:16 +0200
Subject: [PATCH] linux-libre: Enable module compression.

This commit enables GZIP compression for linux-libre kernel modules, reducing
the size of linux-libre by 63% (165MB).

* gnu/packages/aux-files/linux-libre/5.8-arm.conf: Enable GZ compression.
* gnu/packages/aux-files/linux-libre/5.8-arm64.conf: Ditto.
* gnu/packages/aux-files/linux-libre/5.8-i686.conf: Ditto.
* gnu/packages/aux-files/linux-libre/5.8-x86_64.conf: Ditto.
---
 gnu/packages/aux-files/linux-libre/5.8-arm.conf    | 4 +++-
 gnu/packages/aux-files/linux-libre/5.8-arm64.conf  | 4 +++-
 gnu/packages/aux-files/linux-libre/5.8-i686.conf   | 4 +++-
 gnu/packages/aux-files/linux-libre/5.8-x86_64.conf | 4 +++-
 4 files changed, 12 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/aux-files/linux-libre/5.8-arm.conf b/gnu/packages/aux-files/linux-libre/5.8-arm.conf
index 8a1f5ada3f8..bd274d15536 100644
--- a/gnu/packages/aux-files/linux-libre/5.8-arm.conf
+++ b/gnu/packages/aux-files/linux-libre/5.8-arm.conf
@@ -879,7 +879,9 @@ CONFIG_MODULE_FORCE_UNLOAD=y
 CONFIG_MODVERSIONS=y
 # CONFIG_MODULE_SRCVERSION_ALL is not set
 # CONFIG_MODULE_SIG is not set
-# CONFIG_MODULE_COMPRESS is not set
+CONFIG_MODULE_COMPRESS=y
+CONFIG_MODULE_COMPRESS_GZIP=y
+# CONFIG_MODULE_COMPRESS_XZ is not set
 # CONFIG_MODULE_ALLOW_MISSING_NAMESPACE_IMPORTS is not set
 # CONFIG_UNUSED_SYMBOLS is not set
 # CONFIG_TRIM_UNUSED_KSYMS is not set
diff --git a/gnu/packages/aux-files/linux-libre/5.8-arm64.conf b/gnu/packages/aux-files/linux-libre/5.8-arm64.conf
index fa017d5edb0..1e58a3c717e 100644
--- a/gnu/packages/aux-files/linux-libre/5.8-arm64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.8-arm64.conf
@@ -799,7 +799,9 @@ CONFIG_MODVERSIONS=y
 CONFIG_ASM_MODVERSIONS=y
 # CONFIG_MODULE_SRCVERSION_ALL is not set
 # CONFIG_MODULE_SIG is not set
-# CONFIG_MODULE_COMPRESS is not set
+CONFIG_MODULE_COMPRESS=y
+CONFIG_MODULE_COMPRESS_GZIP=y
+# CONFIG_MODULE_COMPRESS_XZ is not set
 # CONFIG_MODULE_ALLOW_MISSING_NAMESPACE_IMPORTS is not set
 # CONFIG_UNUSED_SYMBOLS is not set
 # CONFIG_TRIM_UNUSED_KSYMS is not set
diff --git a/gnu/packages/aux-files/linux-libre/5.8-i686.conf b/gnu/packages/aux-files/linux-libre/5.8-i686.conf
index 9f5d56aeee5..f73c41b6d56 100644
--- a/gnu/packages/aux-files/linux-libre/5.8-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/5.8-i686.conf
@@ -840,7 +840,9 @@ CONFIG_MODVERSIONS=y
 CONFIG_ASM_MODVERSIONS=y
 CONFIG_MODULE_SRCVERSION_ALL=y
 # CONFIG_MODULE_SIG is not set
-# CONFIG_MODULE_COMPRESS is not set
+CONFIG_MODULE_COMPRESS=y
+CONFIG_MODULE_COMPRESS_GZIP=y
+# CONFIG_MODULE_COMPRESS_XZ is not set
 # CONFIG_MODULE_ALLOW_MISSING_NAMESPACE_IMPORTS is not set
 CONFIG_UNUSED_SYMBOLS=y
 CONFIG_MODULES_TREE_LOOKUP=y
diff --git a/gnu/packages/aux-files/linux-libre/5.8-x86_64.conf b/gnu/packages/aux-files/linux-libre/5.8-x86_64.conf
index 40b31388d1b..cd2706357d4 100644
--- a/gnu/packages/aux-files/linux-libre/5.8-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/5.8-x86_64.conf
@@ -844,7 +844,9 @@ CONFIG_MODVERSIONS=y
 CONFIG_ASM_MODVERSIONS=y
 CONFIG_MODULE_SRCVERSION_ALL=y
 # CONFIG_MODULE_SIG is not set
-# CONFIG_MODULE_COMPRESS is not set
+CONFIG_MODULE_COMPRESS=y
+CONFIG_MODULE_COMPRESS_GZIP=y
+# CONFIG_MODULE_COMPRESS_XZ is not set
 # CONFIG_MODULE_ALLOW_MISSING_NAMESPACE_IMPORTS is not set
 CONFIG_UNUSED_SYMBOLS=y
 CONFIG_MODULES_TREE_LOOKUP=y
-- 
GitLab