From 606a106fcc6e820e8b3a3c8b646d68a753f1fd09 Mon Sep 17 00:00:00 2001
From: Mark H Weaver <mhw@netris.org>
Date: Tue, 21 Jul 2015 15:06:38 -0400
Subject: [PATCH] gnu: hoedown: Replace 'fix-makefile' phase with make-flags.

* gnu/packages/markdown.scm (hoedown)[arguments]: Remove 'fix-makefile' phase.
  Add equivalent make-flags.
---
 gnu/packages/markdown.scm | 10 ++--------
 1 file changed, 2 insertions(+), 8 deletions(-)

diff --git a/gnu/packages/markdown.scm b/gnu/packages/markdown.scm
index 58ca10277ad..ee0edfc3490 100644
--- a/gnu/packages/markdown.scm
+++ b/gnu/packages/markdown.scm
@@ -38,14 +38,8 @@ (define-public hoedown
                "0mmmkfayqgh6k39kbi3pq68mg03x35aiygy3zypxzvwx9y8b53ky"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (add-before 'build 'fix-makefile
-                              (lambda* (#:key outputs #:allow-other-keys)
-                                (setenv "CC" "gcc")
-                                (substitute* '("Makefile")
-                                  (("/usr/local")
-                                   (assoc-ref outputs "out")))
-                                #t))
+     '(#:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
+       #:phases (modify-phases %standard-phases
                   (delete 'configure)) ; no configure script
        #:test-target "test"))
     (native-inputs
-- 
GitLab