diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2febd12ff7f58dd7853622724db712fe100ac6ad..110d0995bb18a4d7653f1763e96e2abcfc708767 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -184,10 +184,11 @@ (define-public ffmpeg
         (lambda* (#:key outputs #:allow-other-keys)
           (let* ((out (assoc-ref outputs "out"))
                  (lib (string-append out "/lib")))
-            ;; Add LIB to the RUNPATH of all the executables.
+            ;; Add LIB to the RUNPATH of all the executables and libraries.
             (with-directory-excursion out
               (for-each (cut augment-rpath <> lib)
-                        (find-files "bin" ".*")))))
+                        (append (find-files "bin" ".*")
+                                (find-files "lib" "\\.so\\..*\\."))))))
           %standard-phases))))
     (home-page "http://www.ffmpeg.org/")
     (synopsis "Audio and video framework")