From 622c8f0af2caaa1c6698219a89de4aa6eac11b4f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@gmail.com>
Date: Fri, 16 Jan 2015 22:10:26 +0800
Subject: [PATCH] gnu: ffmpeg: Augment rpath of libraries.

* gnu/packages/video.scm (ffmpeg)[arguments]<phases>[add-lib-to-run-path]:
  Add $out/lib to the RUNPATH of libraries.
---
 gnu/packages/video.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2febd12ff7f..110d0995bb1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -184,10 +184,11 @@ (define-public ffmpeg
         (lambda* (#:key outputs #:allow-other-keys)
           (let* ((out (assoc-ref outputs "out"))
                  (lib (string-append out "/lib")))
-            ;; Add LIB to the RUNPATH of all the executables.
+            ;; Add LIB to the RUNPATH of all the executables and libraries.
             (with-directory-excursion out
               (for-each (cut augment-rpath <> lib)
-                        (find-files "bin" ".*")))))
+                        (append (find-files "bin" ".*")
+                                (find-files "lib" "\\.so\\..*\\."))))))
           %standard-phases))))
     (home-page "http://www.ffmpeg.org/")
     (synopsis "Audio and video framework")
-- 
GitLab