From 62fe2d47529b2c4dd757bb0c211d0515610ea6a5 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Sun, 21 Feb 2016 10:56:50 +0200
Subject: [PATCH] gnu: xvid: Use 'modify-phases'.

* gnu/packages/video.scm (xvid)[arguments]: Use 'modify-phases'.
---
 gnu/packages/video.scm | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index ab1cae803f5..54fdde0046f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1170,13 +1170,13 @@ (define-public xvid
     (native-inputs `(("yasm" ,yasm)))
     (arguments
      '(#:phases
-       (alist-cons-before
-        'configure 'pre-configure
-        (lambda _
-          (chdir "build/generic")
-          (substitute* "configure"
-            (("#! /bin/sh") (string-append "#!" (which "sh")))))
-        %standard-phases)
+       (modify-phases %standard-phases
+         (add-before
+          'configure 'pre-configure
+          (lambda _
+            (chdir "build/generic")
+            (substitute* "configure"
+              (("#! /bin/sh") (string-append "#!" (which "sh")))))))
        ;; No 'check' target.
        #:tests? #f))
     (home-page "https://www.xvid.com/")
-- 
GitLab