From 63f76ab29e69ef503ab1fb5e11255ba2caa02a3c Mon Sep 17 00:00:00 2001
From: Julien Lepiller <julien@lepiller.eu>
Date: Sun, 12 Jan 2020 23:49:47 +0100
Subject: [PATCH] gnu: add python-httmock.

* gnu/packages/python-check.scm (python-httmock): New variable.
---
 gnu/packages/python-check.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index d322121b79b..a69619b96a4 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -313,3 +313,25 @@ (define-public python-codacy-coverage
 of the code is covered by them.  This tool is part of the Codacy suite for
 analysing code quality.")
     (license license:expat)))
+
+(define-public python-httmock
+  (package
+    (name "python-httmock")
+    (version "1.3.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "httmock" version))
+        (sha256
+         (base32
+          "1zj1fcm0n6f0wr9mr0hmlqz9430fnr5cdwd5jkcvq9j44bnsrfz0"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:tests? #f)); no tests
+    (propagated-inputs
+     `(("python-requests" ,python-requests)))
+    (home-page "https://github.com/patrys/httmock")
+    (synopsis "Mocking library for requests.")
+    (description "This package provides a library for replying fake data to
+Python software under test, when they make an HTTP query.")
+    (license license:asl2.0)))
-- 
GitLab