From 64661754fd8a32b9298d24e815cdbe568a8ffe77 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Sat, 10 Oct 2020 00:52:24 -0400
Subject: [PATCH] gnu: FFmpeg: Add support for Secure Reliable Transport (SRT).

* gnu/packages/video.scm (vlc)[inputs] Add srt-1.4.1.
[arguments]: Pass "--enable-libsrt" to #:configure-flags.
---
 gnu/packages/video.scm | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7f0b203f746..8d80409401f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1455,6 +1455,8 @@ (define-public ffmpeg
        ("sdl" ,sdl2)
        ("soxr" ,soxr)
        ("speex" ,speex)
+       ;; FFmpeg is not yet compatible with SRT > 1.4.1.
+       ("srt" ,srt-1.4.1)
        ("twolame" ,twolame)
        ("vidstab" ,vidstab)
        ("x265" ,x265)
@@ -1539,6 +1541,7 @@ (define-public ffmpeg
                '())
          "--enable-libsoxr"
          "--enable-libspeex"
+         "--enable-libsrt"
          "--enable-libtheora"
          "--enable-libtwolame"
          "--enable-libvidstab"
-- 
GitLab