diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index ec3adf13a46c772c00ca438d76758fb0a0940e02..9db543199c966e60964f65defda6eb730b076191 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -139,8 +139,10 @@ (define-public gimp
      `(("pkg-config" ,pkg-config)
        ("intltool" ,intltool)))
     (home-page "http://gimp.org")
-    (synopsis "Image manipulation program.")
-    (description "GIMP is the GNU Image Manipulation Program. It is a freely
-distributed piece of software for such tasks as photo retouching, image
-composition and image authoring.")
+    (synopsis "GNU Image Manipulation Program")
+    (description
+     "GIMP is an application for image manipulation tasks such as photo
+retouching, composition and authoring.  It supports all common image formats
+as well as specialized ones.  It features a highly customizable interface
+that is extensible via a plugin system.")
     (license license:gpl3+))) ; some files are lgplv3
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 36ba0bd3d36cbd7b045bd2a47de7f617479cea2c..6f92cac55ea3c297b685f79624d71e07d81bc20b 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -207,8 +207,8 @@ (define (dynamic-link-substitute file lib input)
                                             "freeglut"))
                  %standard-phases)))
     (home-page "http://gnu.org/s/guile-opengl")
-    (synopsis "OpenGL bindings for Guile")
+    (synopsis "Guile binding for the OpenGL graphics API")
     (description
-     "GNU Guile-OpenGL is a library providing access to the OpenGL graphics
-API from GNU Guile.")
+     "Guile-OpenGL is a library for Guile that provides bindings to the
+OpenGL graphics API.")
     (license l:lgpl3+)))
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fbed6807334ae3cef3ae38846e56b6a155e95cc9..a043d8d4d27c994a5652152a96fa69f716829398 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1178,9 +1178,13 @@ (define-public gnumeric
      `(("intltool" ,intltool)
        ("pkg-config" ,pkg-config)))
     (home-page "http://www.gnumeric.org")
-    (synopsis "Spreadsheet program")
-    (description "Gnumeric is a spreadsheet program for GNOME.  The project aims
-to become a drop in replacement for proprietary spreadsheets.")
-    (license 
+    (synopsis "Spreadsheet application")
+    (description
+     "GNUmeric is a GNU spreadsheet application, running under GNOME.  It is
+interoperable with other spreadsheet applications.  It has a vast array of
+features beyond typical spreadsheet functionality, such as support for linear
+and non-linear solvers, statistical analysis, and telecommunication
+engineering.")
+    (license
     ;; Dual licensed under GPLv2 or GPLv3 (both without "or later")
      (list license:gpl2 license:gpl3))))