From 670398751e982bfc17cc6c1f2bf155a9ca7c9bce Mon Sep 17 00:00:00 2001
From: Eric Dvorsak <eric@dvorsak.fr>
Date: Sat, 25 Jul 2015 21:35:35 +0200
Subject: [PATCH] gnu: Add python-ecdsa.

* gnu/packages/python.scm (python-ecdsa, python2-ecdsa): New variables.

Signed-off-by: Alex Kost <alezost@gmail.com>
---
 gnu/packages/python.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a3802a42e01..817b6cdd1b6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -298,6 +298,40 @@ (define-public python-psutil
 (define-public python2-psutil
   (package-with-python2 python-psutil))
 
+(define-public python-ecdsa
+  (package
+    (name "python-ecdsa")
+    (version "0.13")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://pypi.python.org/packages/source/e/ecdsa/ecdsa-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1yj31j0asmrx4an9xvsaj2icdmzy6pw0glfpqrrkrphwdpi1xkv4"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools" ,python-setuptools)))
+    (inputs
+     `(("openssl" ,openssl)))
+    (home-page
+     "http://github.com/warner/python-ecdsa")
+    (synopsis
+     "ECDSA cryptographic signature library (pure python)")
+    (description
+     "This is an easy-to-use implementation of ECDSA cryptography (Elliptic
+Curve Digital Signature Algorithm), implemented purely in Python.  With this
+library, you can quickly create keypairs (signing key and verifying key), sign
+messages, and verify the signatures.  The keys and signatures are very short,
+making them easy to handle and incorporate into other protocols.")
+    (license license:expat)))
+
+(define-public python2-ecdsa
+  (package-with-python2 python-ecdsa))
+
 (define-public python-ccm
   (package
     (name "python-ccm")
-- 
GitLab