From 67a86d3b8d17b921728eec7776677582cfdd9266 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ludovic=20Court=C3=A8s?= <ludo@gnu.org>
Date: Fri, 17 Oct 2014 23:08:45 +0200
Subject: [PATCH] gnu: valgrind: Don't build on mipsel64-linux.

* gnu/packages/valgrind.scm (valgrind): Add 'supported-systems'.
---
 gnu/packages/valgrind.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 82e3b80f7f8..44a83812354 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -60,4 +60,8 @@ (define-public valgrind
 tools.  There are Valgrind tools that can automatically detect many memory
 management and threading bugs, and profile your programs in detail. You can
 also use Valgrind to build new tools.")
-    (license gpl2+)))
+    (license gpl2+)
+
+    ;; Building VEX on mips64el-linux fails with "opcode not supported on this
+    ;; processor: mips3".
+    (supported-systems (delete "mips64el-linux" %supported-systems))))
-- 
GitLab