From 691cb22b1b4be122fc67d51c890e9fbf1643a182 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@gmail.com>
Date: Wed, 15 Apr 2015 12:41:21 +0800
Subject: [PATCH] gnu: fltk: Add $libdir to the RUNPATH of binaries.

* gnu/packages/fltk.scm (fltk)[arguments]: Add
  DSOFLAGS=-Wl,-rpath=$libdir to #:configure-flags.
---
 gnu/packages/fltk.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/fltk.scm b/gnu/packages/fltk.scm
index 5c872cb233d..1ac1f2507e3 100644
--- a/gnu/packages/fltk.scm
+++ b/gnu/packages/fltk.scm
@@ -42,7 +42,9 @@ (define-public fltk
         ("mesa" ,mesa)))
     (arguments
      `(#:tests? #f                      ;TODO: compile programs in "test" dir
-       #:configure-flags '("--enable-shared")
+       #:configure-flags
+       (list "--enable-shared"
+             (string-append "DSOFLAGS=-Wl,-rpath=" %output "/lib"))
        #:phases
        (alist-cons-before
         'configure 'patch-makeinclude
-- 
GitLab