From 69361e8881a79897e370322aedde9e6f459e26be Mon Sep 17 00:00:00 2001
From: Mathieu Othacehe <othacehe@gnu.org>
Date: Mon, 27 Jul 2020 15:48:28 +0200
Subject: [PATCH] gnu: lzlib: Use url-fetch instead of git-fetch.

* gnu/packages/guile.scm (guile-lzlib)[source]: Use url-fetch instead of
git-fetch.
---
 gnu/packages/guile.scm | 19 +++++++++----------
 1 file changed, 9 insertions(+), 10 deletions(-)

diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 4babff27236..4b7577f2a29 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -813,16 +813,15 @@ (define-public guile-lzlib
   (package
     (name "guile-lzlib")
     (version "0.0.1")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://notabug.org/guile-lzlib/guile-lzlib.git")
-                    (commit version)))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0ny4pbig5x1lv83b63c2613gwv98myk3rm44l88ic7lrff6cd2hr"))
-              (modules '((guix build utils)))))
+    (source
+     (origin
+       (method url-fetch)
+       (uri
+        (string-append "https://notabug.org/guile-lzlib/guile-lzlib/archive/"
+                       version ".tar.gz"))
+       (sha256
+        (base32
+         "0rdmszn1qix085ci2mddwq5cypipc004fk7arrrkgn9bv39hazza"))))
     (build-system gnu-build-system)
     (arguments
      '(#:make-flags
-- 
GitLab