diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 60890bf7246711bc57d979a41f166a97e1a59799..6c970700a529e56500d5f3568acf8e346232f35f 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -632,7 +632,16 @@ (define-public go-gopkg.in-tomb.v2
                   "1sv15sri99szkdz1bkh0ir46w9n8prrwx5hfai13nrhkawfyfy10"))))
       (build-system go-build-system)
       (arguments
-       '(#:import-path "gopkg.in/tomb.v2"))
+       '(#:import-path "gopkg.in/tomb.v2"
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'patch-source
+             (lambda _
+               ;; Add a missing % to fix the compilation of this test
+               (substitute* "src/gopkg.in/tomb.v2/tomb_test.go"
+                 (("t.Fatalf\\(`Killf\\(\"BO%s")
+                  "t.Fatalf(`Killf(\"BO%%s"))
+               #t)))))
       (synopsis "@code{tomb} handles clean goroutine tracking and termination")
       (description
        "The @code{tomb} package handles clean goroutine tracking and