From 69a64ecd66733e394a3b116b38f67b354dcebcc9 Mon Sep 17 00:00:00 2001
From: Christopher Baines <mail@cbaines.net>
Date: Tue, 4 Dec 2018 19:44:47 +0000
Subject: [PATCH] gnu: go-gopkg.in-tomb.v2: Fix build.

Looks like this test isn't compiling with newer versions of go, so fix it to
get the package building again.

* gnu/packages/golang.scm (go-gopkg.in-tomb.v2)[arguments]: Add new
patch-source phase.
---
 gnu/packages/golang.scm | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 60890bf7246..6c970700a52 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -632,7 +632,16 @@ (define-public go-gopkg.in-tomb.v2
                   "1sv15sri99szkdz1bkh0ir46w9n8prrwx5hfai13nrhkawfyfy10"))))
       (build-system go-build-system)
       (arguments
-       '(#:import-path "gopkg.in/tomb.v2"))
+       '(#:import-path "gopkg.in/tomb.v2"
+         #:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'patch-source
+             (lambda _
+               ;; Add a missing % to fix the compilation of this test
+               (substitute* "src/gopkg.in/tomb.v2/tomb_test.go"
+                 (("t.Fatalf\\(`Killf\\(\"BO%s")
+                  "t.Fatalf(`Killf(\"BO%%s"))
+               #t)))))
       (synopsis "@code{tomb} handles clean goroutine tracking and termination")
       (description
        "The @code{tomb} package handles clean goroutine tracking and
-- 
GitLab