diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 704fe491227f7d5ffd2677ec3ec04fc815c0579a..69b6c921e8a63b47e5c4ad57ca997fb52a55c843 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -413,8 +413,8 @@ (define* (make-linux-libre version hash supported-systems
 It has been modified to remove all non-free binary blobs.")
     (license license:gpl2)))
 
-(define %linux-libre-version "4.20.3")
-(define %linux-libre-hash "0mk996fb4bd9548xnv2as4lxm3gyj1kvn6ra03xxpb0wf8cqdazz")
+(define %linux-libre-version "4.20.4")
+(define %linux-libre-hash "1p7ixkqvnr0mzyivyby8hfix44np7w1nvyxghz8wa1h2nhsszvzv")
 
 (define %linux-libre-4.20-patches
   (list %boot-logo-patch