diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 0f15685d3335c0cacc3c9dd831f4c2d0dd9a16cb..a2874be1a8a7a897253dece0e45a052bdc44dc2b 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -487,8 +487,9 @@ (define-public jbig2dec
     (source
       (origin
         (method url-fetch)
-        (uri (string-append "http://downloads.ghostscript.com/public/" name "/"
-                            name "-" version ".tar.gz"))
+        (uri
+         (string-append "https://github.com/ArtifexSoftware/ghostpdl-downloads/"
+                        "releases/download/gs922/" name "-" version ".tar.gz"))
         (sha256
           (base32 "0k01hp0q4275fj4rbr1gy64svfraw5w7wvwl08yjhvsnpb1rid11"))
         (patches (search-patches "jbig2dec-ignore-testtest.patch"))))
@@ -504,7 +505,7 @@ (define-public jbig2dec
 stage, meaning it doesn't completely work yet.  However, it is
 maintaining parity with available encoders, so it is useful for real
 work.")
-    (home-page "http://www.ghostscript.com/jbig2dec.html")
+    (home-page "https://jbig2dec.com")
     (license license:gpl2+)))
 
 (define-public openjpeg