diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index b858a353597fd32319a1d342a8ab2b0c01850e55..d233940f234a3fa0f39dc2e5789a817789522877 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1913,7 +1913,7 @@ (define-public openal
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "http://kcat.strangesoft.net/openal-releases/openal-soft-"
+                    "http://openal-soft.org/openal-releases/openal-soft-"
                     version ".tar.bz2"))
               (sha256
                (base32
@@ -1950,7 +1950,7 @@ (define-public openal
 including air absorption, occlusion, and environmental reverb, are available
 through the EFX extension.  It also facilitates streaming audio, multi-channel
 buffers, and audio capture.")
-    (home-page "http://kcat.strangesoft.net/openal.html")
+    (home-page "http://openal-soft.org/")
     (license license:lgpl2.0+)))
 
 (define-public freealut