diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 826720ccd5dfb34028cfcd101d0c4a6068bbf820..789e199f5181358f423cbed4df120bf277d549df 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -797,14 +797,13 @@ (define-public python-mock
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://pypi.python.org/packages/source/m/mock/"
-                           "mock-" version ".tar.gz"))
+       (uri (pypi-uri "mock" version))
        (sha256
         (base32
          "0kzlsbki6q0awf89rc287f3aj8x431lrajf160a70z0ikhnxsfdq"))))
     (build-system python-build-system)
     (arguments '(#:test-target "check"))
-    (home-page "http://code.google.com/p/mock/")
+    (home-page "https://github.com/testing-cabal/mock")
     (synopsis "Python mocking and patching library for testing")
     (description
      "Mock is a library for testing in Python.  It allows you to replace parts